Search found 52 matches

by sadams54
Wednesday 14th October 2020 9:06pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

Problem solved. Thank you everybody. I used the pcode option and even though it did not work, I tried it again on a 3.15 system and made the executable there. Copied it over and back to full functionality. Thank you for the information it will be committed to my notes for future use.
by sadams54
Monday 12th October 2020 6:36pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

I tried fedora on the pi and it had serious deficiencies. Now of course I am using pi4 and fedora is not doing that one yet. At least according to what I read. I would love fedora on the pi4 it would be a dream.
by sadams54
Saturday 10th October 2020 5:54pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer (solved)

I will keep working to get this to work but I wonder about how much energy to put in. I did the environment variable and confirmed it is still in there. But I wonder about all the work to patch around something that just needs updated. Raspian is behind due to this in my mind. I can work using the I...
by sadams54
Saturday 10th October 2020 1:17am
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

removed the contents of .gambas but was not able to make progress. also could not compile anything. I put the files back in and was then able to run the program in the IDE but all complied versions on that machine said that now could not load fmain. Thinking I'll have to wait until the gambas runtim...
by sadams54
Friday 09th October 2020 11:14pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

OK, now this is making more sense. I will try the deletion of the .gambas folder and see if I can get it to clean compile. The program is already installed using the install package. By program I mean the one I wrote. I have the program on several computers. I have found that once you create the exe...
by sadams54
Thursday 08th October 2020 11:27pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

I originally set up using gambas 3.15 on other system. Never had a problem like this before. it just always worked. I tried to remove gambas on the pi and it didn't seem to actually remove it. But when I go to install gambas I only see 3.12 available. I am sure this needs to be updated which is what...
by sadams54
Wednesday 07th October 2020 9:46pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

Thanks for the advice. I put in the variable and made a new executable but same exact error. The problem does not exist on my fedora systems so must be problem on the pi version
by sadams54
Wednesday 07th October 2020 8:08pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Re: Can't run on Pi any longer

nope. Tried that before posting and even attempting to run the project in a full gambas on the pi gives that same error in gambas editor. I tried making new executable on the pi and when I go to run it, same error.
by sadams54
Wednesday 07th October 2020 6:43pm
Forum: General
Topic: Can't run on Pi any longer
Replies: 25
Views: 1274

Can't run on Pi any longer

I have been running some of my work on the raspberry pi. Works nice until now. when I attempt to run a new verson of the programs I wrote I get this... ERROR: #2: Cannot load class 'FMain': Bytecode too recent. Please upgrade Gambas. Gambas is up to date on the pi. Version 3.12.2 When I to the apt-g...
by sadams54
Thursday 01st October 2020 6:29pm
Forum: General
Topic: unable to create working installation rpm
Replies: 4
Views: 462

Re: unable to create working installation rpm

Hi sadams54, Apparently the package util-linux-2.35.1-1.fc32.x86_64 already contains a file/binary named 'rename'. That's what causes your conflict as your package is also named 'rename' I suggest you name your package differently and try again. Holy crap it was that easy. I sat for months not able...