Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post Reply
User avatar
Godzilla
Posts: 45
Joined: Wednesday 26th September 2018 11:20am

Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by Godzilla » Saturday 18th July 2020 12:04pm

I haven't upgraded to Mint 20 yet, after I heard it has issues with the new version of Gambas. I don't think I need Mint 20 that badly. But is the install of Gambas 3.15 stable painless and problem-free on Mint 19.3?

If so, would then upgrading to Mint 20 bork an otherwise clean-running install of Gambas 3.15 stable?

Thanks.

cage
Posts: 65
Joined: Monday 02nd September 2019 5:47am
Location: Phoenix Arizona

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cage » Saturday 18th July 2020 7:25pm

I wouldn't recommend upgrading to Gambas 3.15. It's buggy with some rather major bugs. All my programs that use images are now negatives. While they display correctly in the IDE they show up as negatives in the running program.

User avatar
cogier
Site Admin
Posts: 485
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cogier » Sunday 19th July 2020 12:24pm

Godzilla
But is the install of Gambas 3.15 stable painless and problem-free on Mint 19.3?
No it's not on either Mint 19.3 or Mint 20. If you want to upgrade Gambas to 3.15 make sure you remove Gambas completely first, I used Synaptic to do this. Then add the ppa, followed by an 'update' and again using Synaptic ensure all and only Gambas 3.15 items are checked for installation. All should be OK after that.

Note that Ubuntu 20.04 and Mint 20 etc. does not use QT4 any more. You need to ensure you are using 'gb.qt5' or 'gb.gui.qt' or 'gb.gui'.

cage
It's buggy with some rather major bugs. All my programs that use images are now negatives.
Have a look as above and make sure you have installed the correct items if you are still having problems can you post an example and a screenshot as I am not getting this issue with 3.15.

cage
Posts: 65
Joined: Monday 02nd September 2019 5:47am
Location: Phoenix Arizona

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cage » Sunday 19th July 2020 11:35pm

Cogier I am running Arch Linux but I will double check what's installed. Apparently this seems to be an Arch problem. But here is a screen shot of both the IDE and the actual running program.

Image

On the left is the IDE and the right is the program actually running.

Okay found the problem. Everything was installed except a couple of things. Neither had to do with graphics, but I found there is a new gb utility that solved the problem. It was gb.immage.effects, now my images are all what they are suppose to be.

bill-lancaster
Posts: 94
Joined: Tuesday 26th September 2017 3:17pm
Location: NW England

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by bill-lancaster » Monday 20th July 2020 8:02am

My kubuntu 18.04 automatically updated me to Gambas 3.15, I then started to get weird errors with several Gambas progs, mostly 'no mouse data available(or something like that) in places where mouse movement wasn't involved.
The IDE is quite different too, form properties now has rather small icons for components as well as other 'improvements'.
I use mysql a lot and haven't had any issues so far.

User avatar
cogier
Site Admin
Posts: 485
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cogier » Monday 20th July 2020 2:08pm

The IDE is quite different too, form properties now has rather small icons for components as well as other 'improvements'.
You can change this by clicking on the magnifying glass.

Image

bill-lancaster
Posts: 94
Joined: Tuesday 26th September 2017 3:17pm
Location: NW England

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by bill-lancaster » Tuesday 21st July 2020 9:11am

Thanks cogier, I hadn't spotted that.

User avatar
Godzilla
Posts: 45
Joined: Wednesday 26th September 2018 11:20am

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by Godzilla » Monday 27th July 2020 7:12am

Taking into consideration the replies to this thread, I decided to test one of my old computers running Mint 19.3 and Gambas 3.14.

Since I needed to do a complete removal of Gambas 3.14 anyway, to do a clean upgrade to 3.15, I decided I'd just go ahead and upgrade the computer to Mint 20 and after doing a full removal of Gambas 3.14. I did the complete removal using the command :

Code: Select all

sudo apt-get purge --auto-remove gambas3
After doing that, I opened Synaptic and did a search for "gambas" to see if there were any leftover installed packages that I'd need to manually remove. Luckily, there weren't any.

Next step, I carefully followed the Mint upgrade instructions here exactly, step-by-step. https://linuxmint-user-guide.readthedoc ... nt-20.html

After that, I re-installed the Gambas stable PPA (all PPAs and everything 3rd party had to be removed prior to the Mint upgrade). Then I installed Gambas 3.15 from the command line.

Code: Select all

sudo apt install gambas3
Then I loaded up and tested some critical Gambas projects that I use regularly. Gambas 3.15 opened and ran without errors. And executed my projects from the IDE without any apparent errors or issues. A big relief! Except for one set of errors, see below.

My projects already use serialization / de-serialization from my own functions and haven't been altered to take advantage of 3.15's built-in S / D functionality (which is a very cool addition, thank you Benoit). My own S / D functions continue to work as expected without any conflict with 3.15's built-in S / D functionality and without having to re-code anything.

Now for the error I had while opening one project. And it may not even mean anything important. I'm guessng just a control size issue. But I don't know what it means. I'm pretty sure I created this project using QT. So IDK why there would be GTK errors. Anyways, here's what I get when opening one of my projects using 3.15 on Mint 20 (I didn't get these errors on Mint 19.3 using Gambas 3.14):

Code: Select all

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)
If anyone knows what I need to do to squash this bug, let me know.

After this experience, I'm pretty confident I should be able to upgrade my main computers to Mint 20 and Gambas 3.15 with no issues.

Thanks for reading.

User avatar
cogier
Site Admin
Posts: 485
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cogier » Monday 27th July 2020 5:40pm

I put a radio button on a Form and made it very small and the warning popped up when the program was run. You must be using 'gb.gui' and I expect there is a small radio button somewhere in your program. You may not even realize that it's there.

User avatar
sjsepan
Posts: 57
Joined: Saturday 12th October 2019 10:11pm
Location: Leeper, PA, USA
Contact:

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by sjsepan » Saturday 01st August 2020 9:09pm

Thanks for the upgrade info; I tried it again your way and I am happy so far, except for a warning similar to yours
--Steve S

Code: Select all

(GambasGuiGeneric:56871): Gtk-WARNING **: 17:03:30.481: for_size smaller than min-size (16 < 17) while measuring gadget (node button
, owner GtkScrollbar)

(GambasGuiGeneric:56871): Gtk-WARNING **: 17:03:30.481: for_size smaller than min-size (16 < 17) while measuring gadget (node button
, owner GtkScrollbar)
Godzilla wrote:
Monday 27th July 2020 7:12am
Taking into consideration the replies to this thread, I decided to test one of my old computers running Mint 19.3 and Gambas 3.14.

[...]
Now for the error I had while opening one project. And it may not even mean anything important. I'm guessng just a control size issue. But I don't know what it means. I'm pretty sure I created this project using QT. So IDK why there would be GTK errors. Anyways, here's what I get when opening one of my projects using 3.15 on Mint 20 (I didn't get these errors on Mint 19.3 using Gambas 3.14):

Code: Select all

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.894: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)

Gtk-WARNING **: 01:41:01.895: for_size smaller than min-size (10 < 16) while measuring gadget (node radio, owner GtkRadioButton)
If anyone knows what I need to do to squash this bug, let me know.


Post Reply