Compiling Gambas on Debian/Raspbian Buster (wiki needs help)

Post Reply
User avatar
BruceSteers
Posts: 149
Joined: Thursday 23rd July 2020 5:20pm

Compiling Gambas on Debian/Raspbian Buster (wiki needs help)

Post by BruceSteers » Sunday 11th October 2020 1:23am

Hi all.
I've sent this to the gambas-user mailing list and am sending it here as well to better my chances of getting this right as it's almost right but it need a little finalising...

There's a couple of things not working and i might have added something that's not needed? (i hope not) any expert advice would be appreciated.

I've spent a whole lot of hours and a whole lot of mobile data doing this for everyone as i figured , someone had to as it hadn't been done since 2017.

I've updated the info on the wiki pages for compiling the latest commits on both Debian and Raspian (Buster) as best as i can, just missing a couple of things (see below). close but not quite there, needs some expert adjustments.

I installed fresh new operating systems on both a Debian pc and a Rapberry PI4
Images:
Debian debian-live-10.4.0-amd64-mate
Raspian 2020-08-20-raspios-buster-armhf.img

i Ran apt-get update and apt-get full-upgrade on both and installed nothing else.

I then installed the dependencies which are as best as i can get them by copy-n-pasting from the lists i've edited on the wiki pages.
http://www.gambaswiki.org/wiki/install/debian#t17
http://www.gambaswiki.org/wiki/install/raspbian#t20
They are very very close but just not quite right darn it . working except the following..

Neither one installed a system menu item for Gambas3 I had to manually add one.

Debian.
Unable to met pkg-config requirement: gnome-keyring-1
gb.desktop.gnome.keyring is disabled
gb.openssl is disabled
All else is okay

Raspbian.
Unable to met pkg-config requirement:Qt5WebEngineWidgets
gb.qt5.webview is disabled
All else is okay.
(qtwebengine5-dev is not available on raspbian)

Like i say i've spent hours on this as the raspberry is slow as hell. and my phone just alerted me i've used 75% of my data and it's like, the 11th :(
So i'm done, someone else can add the finishing touches now.
I've got it best i can and am obviously missing something and could possibly have added something that's not needed.

Apart from the listed components gambas compiles and installs fine on both (apart from the menu item).
BruceS
If at first you don't succeed , try it differently.

User avatar
BruceSteers
Posts: 149
Joined: Thursday 23rd July 2020 5:20pm

Re: Compiling Gambas on Debian/Raspbian Buster (wiki needs help)

Post by BruceSteers » Sunday 11th October 2020 1:26am

Ps.
Will also work (as near as dam it) for stable gambas 3.15.2 or an other specific version you may want to install.
If at first you don't succeed , try it differently.

User avatar
BruceSteers
Posts: 149
Joined: Thursday 23rd July 2020 5:20pm

Re: Compiling Gambas on Debian/Raspbian Buster (wiki needs help)

Post by BruceSteers » Sunday 11th October 2020 9:41pm

List should now all be good. 😊
They are duplicated from the same list a ppa install would use for these disros..

And if you want to compile on another distribution see me other post 😊
If at first you don't succeed , try it differently.

Post Reply