gb.gui error after install

Post Reply
sadams54
Posts: 22
Joined: Monday 09th July 2018 3:43am

gb.gui error after install

Post by sadams54 » Wednesday 24th April 2019 6:11pm

I have created a RPM install package for software. for some reason after I install it on a fresh system it gives "gb.gui: error: unable to find any GUI component"

the gambas3 runtime is installed. This goes away if I install full gambas3 but that is not what I want to do on client systems. I am sure it is something simple or stupid on my part but can somebody please point it out for me?

User avatar
cogier
Site Admin
Posts: 296
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: gb.gui error after install

Post by cogier » Thursday 25th April 2019 12:08pm

What components are you using in your program? You will need to include these as well. What distro are you trying to install on?

sadams54
Posts: 22
Joined: Monday 09th July 2018 3:43am

Re: gb.gui error after install

Post by sadams54 » Monday 29th April 2019 8:13pm

I have the components checked are..

gb
gb.form
gb.form.dialog
gb.gui
gb.image

install is for fedora.
I checked to see if there was a spot to specify these for the install package but I did not see anything. I assume it is picked up from the properties.

User avatar
cogier
Site Admin
Posts: 296
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: gb.gui error after install

Post by cogier » Tuesday 30th April 2019 11:12am

I think you need to add them in Section 7. I have tried this process before with little success. if you do get it to work please let us know how you did it.
Image

User avatar
gbWilly
Posts: 19
Joined: Friday 23rd September 2016 11:41am
Location: Netherlands
Contact:

Re: gb.gui error after install

Post by gbWilly » Monday 27th May 2019 3:57pm

You don need to add them to extra dependencies.
If they are marked as components used in the project their dependency on them will be in the package the Gambas packager makes.

I've been modifying source code of the packager for the debian/ubuntu part at my Gambas repo at work to meet some Debian specific requests in my packages, so I know for sure that the dependencies are set in the package you made in Gambas IDE.

I'm not very familiar with rpm packages, but as far as I could see in the packager code, it is no different than a deb package concerning dependencies.

If the package wouldn't meet the required dependencies, it should not install, but it did.
So the problem lies somewhere else.
Are you running GTK or QT4/5 on your Fedora box?
My first guess is that it might be GTK related.
gbWilly
- Dutch translation for Gambas3
- Gambas wiki content contributer


... there is always a Catch if things go wrong!

sadams54
Posts: 22
Joined: Monday 09th July 2018 3:43am

Re: gb.gui error after install

Post by sadams54 » Monday 27th May 2019 8:02pm

I worked around this by selecting gtk in the properties and deselecting the gb.gui. it works fine that way.

Post Reply