Shell "my_script.sh" To Label1.Text doesn't work any more

Post Reply
abbat81
Posts: 2
Joined: Wednesday 12th June 2019 1:11pm

Shell "my_script.sh" To Label1.Text doesn't work any more

Post by abbat81 » Wednesday 12th June 2019 1:23pm

Hi!
Shell "my_script.sh" To Label1.Text
- doesn't work any more
in my Gambas 3.10 it worked OK, but now nothing happens

[System]
Gambas=3.12.2
Kernel=4.4.0-71-generic
Distribution=Ubuntu 14.04.5 LTS

User avatar
cogier
Site Admin
Posts: 282
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: Shell "my_script.sh" To Label1.Text doesn't work any more

Post by cogier » Wednesday 12th June 2019 1:53pm

Hi abbat81 and welcome to the forum

I tried
Shell "ls" To TextArea1.Text
It worked OK

What does my_script.sh do? Are you aware that support has run out for Ubuntu 14.04?

abbat81
Posts: 2
Joined: Wednesday 12th June 2019 1:11pm

Re: Shell "my_script.sh" To Label1.Text doesn't work any more

Post by abbat81 » Wednesday 12th June 2019 2:25pm

cogier wrote:
Wednesday 12th June 2019 1:53pm
What does my_script.sh do? Are you aware that support has run out for Ubuntu 14.04?
Here is code:
Shell "rm -Rf ~/.tmp && mkdir ~/.tmp && chmod +x ~/.tmp && cd ~/.tmp && wget -i URL/URL_list && sh install_patch.sh" To Label3.Text
It didn't work, but now I fixed by two string:
  Shell "rm -Rf ~/.tmp && mkdir ~/.tmp && chmod +x ~/.tmp && cd ~/.tmp && wget -i URL/My_Soft/URL_list" Wait
  Shell "cd ~/.tmp && sh install_patch.sh" To Label3.Text
Thank you, this topic can be removed

Post Reply