How I Installed Gambas on Ubuntu 20.04

Post Reply
User avatar
cogier
Site Admin
Posts: 507
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

How I Installed Gambas on Ubuntu 20.04

Post by cogier » Wednesday 20th May 2020 4:17pm

How I Installed Gambas on Ubuntu 20.04

Install Synaptic in Terminal with.

Code: Select all

sudo apt-get -y install synaptic
Open Synaptic
Use the search to find gambas3

Mark gambas3 for installation and accept all the other files suggested.
Scroll down the list and check all the gambas3 files not already selected for installation and set them for installation.

Click on 'Apply'.

Once all the files are installed close Synaptic and launch Gambas3.

EDIT 09/06/2020

This is easier, simply run the following in Terminal.

sudo apt-get -y install gambas3 gambas3-gb-form-print gambas3-gb-gtk-opengl gambas3-gb-gtk3 gambas3- gb-gui-opengl gambas3-gb-gui-qt gambas3-gb-gui-qt-webkit gambas3-gb-gui-trayicon gambas3-gb-libxml gambas3-gb-option gambas3-gb-report gambas3-gb-sdl gambas3- gb-sdl-sound gambas3-gb-v4l gambas3-templates

twinsonian
Posts: 4
Joined: Thursday 21st May 2020 11:10am

Re: How I Installed Gambas on Ubuntu 20.04

Post by twinsonian » Monday 15th June 2020 8:22pm

Hello,

Thank you for your instructions.

When attempting to run the sudo apt-get command I end up getting:

E: Unable to locate package gb-gui-opengl
E: Unable to locate package gb-sdl-sound

I wish there was a gambas3 flatpak haha.

EDIT: I am a dumb dumb -- I didnt see the spaces in the command.

This worked for me:
sudo apt install gambas3 gambas3-gb-form-print gambas3-gb-gtk-opengl gambas3-gb-gtk3 gambas3-gb-gui-opengl gambas3-gb-gui-qt gambas3-gb-gui-qt-webkit gambas3-gb-gui-trayicon gambas3-gb-libxml gambas3-gb-option gambas3-gb-report gambas3-gb-sdl gambas3-gb-sdl-sound gambas3-gb-v4l gambas3-templates

User avatar
cogier
Site Admin
Posts: 507
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: How I Installed Gambas on Ubuntu 20.04

Post by cogier » Tuesday 16th June 2020 3:03pm

I am glad it worked for you. It also works on Linux Mint 20 beta.

Post Reply