Search found 677 matches

by BruceSteers
Thursday 25th November 2021 11:01am
Forum: General
Topic: Installing Gambas Runtime
Replies: 8
Views: 139

Re: Installing Gambas Runtime

Okay, so the app uses gb.image.

so...
sudo apt install gambas3-gb-image

then repeat the process until you have the needed additional components.

it might be easier to type...

sudo apt install gambas3

that will install the most common components for you.
by BruceSteers
Thursday 25th November 2021 1:55am
Forum: General
Topic: Installing Gambas Runtime
Replies: 8
Views: 139

Re: Installing Gambas Runtime

You have to type the full path to the file or use ./forms.gambas if in application folder.

Then it will tell you what components are missing.
Most Gambas apps will use some other components than just the runtime
by BruceSteers
Wednesday 24th November 2021 1:51am
Forum: Beginners
Topic: Question about Message class
Replies: 2
Views: 61

Re: Question about Message class

Message should pop to front.
Does Form2 need to be Utility window? a modal window will get top position so maybe a Utility window does too? i'd make both Forms normal to expect normal usage from them both at the same time :)
by BruceSteers
Wednesday 24th November 2021 1:32am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

PS.
You can yourself find if your running app has a parent terminal associated or not by using something like this..

If File.In.IsTerm Then
  ' app has a parent terminal so output formatting may occur
Else
  ' Terminal formatting may not occur
Endif
Just in case you need to know :)
by BruceSteers
Wednesday 24th November 2021 1:24am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

I discovered this by using Quote() in the result to see any differences ;) :lol: I could see the colour codes in the text. The colour codes are interfering with your grep command if you run a gambas app via a terminal or from the IDE it has a stdout terminal stream to use but if just running an app ...
by BruceSteers
Wednesday 24th November 2021 1:17am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

you are not using the "-c 0" flag i mentioned to remove the colour codes! I find it does what you say if i do not omit the colours but it works if i do. without using -c 0 my output running the exe is this... "\x0312CPU: \x03\x0312Topology\x03 Quad Core \x0312model\x03 Intel Core i5-3470S \x0312bits...
by BruceSteers
Wednesday 24th November 2021 1:03am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

Just a note. Gambas uses sh by default in a Shell not bash. Maybe that's the problem? (it may not be but sh does behave differently to bash) To make gambas use bash you have to put the following code in.... Public Sub Form_Open() System.Shell = System.Find("bash") ' Now Shell will use bash not sh En...
by BruceSteers
Tuesday 23rd November 2021 3:56am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

stevedee wrote:
Monday 22nd November 2021 3:21pm
BruceSteers wrote:
Monday 22nd November 2021 3:11pm
...It just seems to add \n line feeds in different places...
That's weird, I get escape characters were you get line feeds (i.e. x1B or 27 decimal)
yeah i used

Shell "inxi -C -c 0" To sText
TextArea1.Text =Quote(sText)

That omitted the color codes and showed the LFs as \n for me.
by BruceSteers
Monday 22nd November 2021 3:11pm
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

Here's the differences i see between exe and IDE.. IDE: "CPU:\n Topology: Quad Core model: Intel Core i5-3470S bits: 64 \n type: MCP L2 cache: 6144 KiB \n Speed: 3260 MHz min/max: 1600/3600 MHz \n Core speeds (MHz): 1: 3306 2: 3307 3: 3245 4: 3460 \n" Exe: "CPU: Topology: Quad Core model: Intel Core...
by BruceSteers
Monday 22nd November 2021 9:58am
Forum: General
Topic: Works in IDE; not when made as an executable
Replies: 19
Views: 307

Re: Works in IDE; not when made as an executable

hi, I found the flag -c 0 stops the colour output.

try this...

Shell "inxi -C -c 0 | grep -o -P '(?<=model:).*(?=bits)'"