Upgrading to 3.16.0

New to Gambas? Post your questions here. No question is too silly or too simple.
Doctor Watson
Posts: 84
Joined: Wednesday 22nd August 2018 7:55am

Upgrading to 3.16.0

Post by Doctor Watson » Wednesday 19th May 2021 3:28am

This is a really humble question.
Is the following going to get me the latest (3.16.0) version ?
I haven’t done any upgrading lately … :oops:
sudo add-apt-repository ppa:gambas-team/gambas3
sudo apt-get update
sudo apt-get upgrade
Old african saying:
You eat an elephant one small bite at a time.

User avatar
stevedee
Posts: 455
Joined: Monday 20th March 2017 6:06pm

Re: Upgrading to 3.16.0

Post by stevedee » Wednesday 19th May 2021 6:23am

Doctor Watson wrote:
Wednesday 19th May 2021 3:28am
...Is the following going to get me the latest (3.16.0) version ?...

sudo add-apt-repository ppa:gambas-team/gambas3
sudo apt-get update
sudo apt-get upgrade
Yes that's pretty much it (if you have a distro based upon Debian or Ubuntu) see this page: https://launchpad.net/~gambas-team/+arc ... tu/gambas3
After you have done this, you will be advised in the future of updates in the normal way.

But before you do this, could I ask a favour Re: my Procedure Folding thread;
With your existing version, could you turn on Procedure Folding via menu Tools > Preferences > Editor and confirm that simply clicking on the + or - signs in the editor margin next to any procedures will fold or unfold the procedure.

This is just a sanity check...a check on my sanity...to confirm my belief that this functionality has changed in v3.16.0 from whichever earlier version you have.

Many thanks Doc

Doctor Watson
Posts: 84
Joined: Wednesday 22nd August 2018 7:55am

Re: Upgrading to 3.16.0

Post by Doctor Watson » Wednesday 19th May 2021 7:05am

Hi Steve.
Yes, every SwitchButton works.
I did already try starting the upgrade and got as far as 'sudo add-apt-repository ppa:gambas-team/gambas3' when I got presented with some stuff I didn't like right away. So I broke it off.
But as it turns out, it seems I can go ahead. Fingers crossed as usual :)
Cheers!
Old african saying:
You eat an elephant one small bite at a time.

Doctor Watson
Posts: 84
Joined: Wednesday 22nd August 2018 7:55am

Re: Upgrading to 3.16.0

Post by Doctor Watson » Wednesday 19th May 2021 7:18am

Oh dear. No, it doesn't work. I got this :
Screenshot from 2021-05-19 09-07-38.png
Screenshot from 2021-05-19 09-07-38.png (147.28 KiB) Viewed 1242 times
Tried anyway but :
Screenshot from 2021-05-19 09-09-18.png
Screenshot from 2021-05-19 09-09-18.png (135.33 KiB) Viewed 1242 times
Back to square 1
Old african saying:
You eat an elephant one small bite at a time.

Doctor Watson
Posts: 84
Joined: Wednesday 22nd August 2018 7:55am

Re: Upgrading to 3.16.0

Post by Doctor Watson » Wednesday 19th May 2021 8:18am

Steve, I forgot to mention.

Yes indeed, in the form class editor clicking on - or + works perfectly.
Old african saying:
You eat an elephant one small bite at a time.

User avatar
stevedee
Posts: 455
Joined: Monday 20th March 2017 6:06pm

Re: Upgrading to 3.16.0

Post by stevedee » Wednesday 19th May 2021 10:41am

Doctor Watson wrote:
Wednesday 19th May 2021 8:18am
...Yes indeed, in the form class editor clicking on - or + works perfectly.
Thanks for the confirmation Doc.

With your install problem, it looks like you need to disable (or remove) the noobs ppa, because that's the one giving you grief.

Doctor Watson
Posts: 84
Joined: Wednesday 22nd August 2018 7:55am

Re: Upgrading to 3.16.0

Post by Doctor Watson » Thursday 20th May 2021 4:47am

I would like to try that Steve, but how do I disable or remove this noobs ppa ?
I already visited https://launchpad.net/~gambas-team/+arc ... tu/gambas3
and tried - as they suggest:
Adding this PPA to your system
You can update your system with unsupported packages from this untrusted PPA by adding ppa:gambas-team/gambas3 to your system's Software Sources. (Read about installing)
sudo add-apt-repository ppa:gambas-team/gambas3
sudo apt-get update
That produces exactly the same message:
Err:10 http://ppa.launchpad.net/noobslab/themes/ubuntu focal Release
404 Not Found [IP: 91.189.95.85 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/noobslab/themes/ubuntu focal Release' does not have a Release file.
"404 Not Found [IP: 91.189.95.85 80]" ? Could it be that noobslab is no longer working at all or doesn’t have the latest Gambas version.
And if that is the case, I wonder if Benoit is aware of that.
Old african saying:
You eat an elephant one small bite at a time.

User avatar
BruceSteers
Posts: 652
Joined: Thursday 23rd July 2020 5:20pm

Re: Upgrading to 3.16.0

Post by BruceSteers » Thursday 20th May 2021 5:21am

http://ppa.launchpad.net/noobslab/themes/ubuntu
has nothing to do with gambas and nothing to do with Benoit

ppa:gambas-team/gambas-daily is trunk version
ppa:gambas-team/gambas3 is stable version

load your software sources app and remove erroneous ppa's

you could upgrade gambas by typing...
apt-get remove gambas3*
apt-get install gambas3*

using apt-get upgrade wants to upgrade everything
Wishing well
Bruce

If at first you don't succeed , try it differently.

User avatar
stevedee
Posts: 455
Joined: Monday 20th March 2017 6:06pm

Re: Upgrading to 3.16.0

Post by stevedee » Thursday 20th May 2021 6:43am

Doctor Watson wrote:
Thursday 20th May 2021 4:47am
I would like to try that Steve, but how do I disable or remove this noobs ppa ?...
Hi Doc, If you have Synaptic installed (...which is still my favourite program for installing/removing packages) navigate menu Settings > Repositories > Other Software
PPA.png
PPA.png (111.97 KiB) Viewed 1199 times
I think you can select (highlight) the noobs ppa and then you have the choice of removing it, or if you just un-tick it then I think it will disable it (i.e. stop it trying to update).

I hope that helps, but come back if not.

User avatar
BruceSteers
Posts: 652
Joined: Thursday 23rd July 2020 5:20pm

Re: Upgrading to 3.16.0

Post by BruceSteers » Thursday 20th May 2021 2:03pm

Another thing is ....
nothing went wrong with gambas ppa updating.

your screenshot image shows all your ppa links updated okay but that noobs one did not. (no biggie)
gambas ppa should still update okay

Here is my recomendation...
Run..
sudo apt-get remove gambas3*

Then load synaptic package manager
Select "Origin" from the list and select the gambas repository.
Install gambas components from there.

Or go for the autotools method (Compiling from source)
Note: apt does not recognise autotools method meaning after installing via compile apt will report gambas is not installed and you must not use apt to install any gambas components as the compile install installs them all anyway.
Wishing well
Bruce

If at first you don't succeed , try it differently.

Post Reply