segmentation fault

Post Reply
salihburhan
Posts: 8
Joined: Thursday 24th October 2019 2:14pm

segmentation fault

Post by salihburhan » Thursday 20th February 2020 1:09pm

I have a new computer that I put Debian testing (bullseye).
Normally, everything is fine in Debian stable. This one gives segmentation fault when I run the program.
It compiles as expected. Does not run though.
I have no clue why.
Could not report it either. The mail bounced. The crash report is here:



=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Hello,

Damned, my program crashed Gambas that way :

When I run the program, it gives a segmentation fault.
Btw, the same code runs fine on debian 10.3.
The system is, debian testing weekly as of midFebruary.




gdb) run
Starting program: /usr/bin/gbx3
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Detaching after vfork from child process 4089]
[New Thread 0x7ffff1ae3700 (LWP 4091)]
[New Thread 0x7fffeadea700 (LWP 4095)]

Thread 1 "gbx3" received signal SIGSEGV, Segmentation fault.
0x00007ffff5e3dbd4 in QCoreApplication::postEvent(QObject*, QEvent*, int) ()
from /lib/x86_64-linux-gnu/libQt5Core.so.5

User avatar
cogier
Site Admin
Posts: 424
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: segmentation fault

Post by cogier » Thursday 20th February 2020 2:31pm

The problem seems to have something to do with QT.

Have a look in Synaptic to ensure all the Gambas QT components have been installed and if not install them.

Image

You could try changing the toolkit. Try any or all of the following gb.gui, gb.gui.qt, gb.gtk3,gb.qt4, gb.qt5.

However, without the program itself it's a little difficult to work out what's wrong. If none of this works can we see the program?

salihburhan
Posts: 8
Joined: Thursday 24th October 2019 2:14pm

Re: segmentation fault

Post by salihburhan » Wednesday 26th February 2020 11:11am

Thanks for the reply..
I have all gambas components installed: gambas3*
I can post the software, but it is a bit large. We are using an ERP I wrote in gambas.
The thing is, it works well from fedora25-31 and debian 9.3 - 10.3..
I think it is a library problem related to debian 11: I am using debian tesing in my laptop.
How do I figure it out?
The same binary xxx.gambas that runs in others gives segmentation fault.
Here is the code that raises the error:

- dbConn provides Connection

Public Sub _init()
ntParam = New Settings(Application.Path & "/nt.v2.config")
dbConn = New DbConnection
zamanla = New Timer As "tetik"
zamanla.Delay = 300000
zamanla.Enabled = True
zamanla.Start
Try dbConn.get_connection().Open()
If Error Then
is_online = False
bl_offline.get_productsFromFile(False)
Return
Else
is_online = True
secure = New Bl_security
email = New Bl_email

If ntParam["diğer/use_backup_server"] = "yes" Then dbConn.init_slave()
Endif
End --------------------------> error after this line..




Thanks....

salihburhan
Posts: 8
Joined: Thursday 24th October 2019 2:14pm

Re: segmentation fault

Post by salihburhan » Tuesday 10th March 2020 7:56am

UPDATE:

The same problem comes up after fedora upgrade to v. 30.

Post Reply