Gambas runtime 3.16.0

Post your Gambas programming questions here.
Post Reply
AndyGable
Posts: 83
Joined: Wednesday 02nd December 2020 12:11am
Location: England
Contact:

Gambas runtime 3.16.0

Post by AndyGable » Friday 04th June 2021 3:08pm

Hi everyone,

I hope someone could advice me on the following

I am using Gambas 3.16.0 (built from source) and its runs great and i am steaming ahead with my project

Now my question is how do I make the runtime files so I can install my app onto another computer?

Do I have to rebuild and install 3.16.0 on every computer that I want my app to run on

As Debian only have 3.14 in the repo at the moment.

User avatar
stevedee
Posts: 446
Joined: Monday 20th March 2017 6:06pm

Re: Gambas runtime 3.16.0

Post by stevedee » Friday 04th June 2021 3:54pm

AndyGable wrote:
Friday 04th June 2021 3:08pm
...Now my question is how do I make the runtime files so I can install my app onto another computer?
Gambas IDE menu Project > Make > Installation package...

AndyGable
Posts: 83
Joined: Wednesday 02nd December 2020 12:11am
Location: England
Contact:

Re: Gambas runtime 3.16.0

Post by AndyGable » Friday 04th June 2021 6:29pm

Is it that simple 🤣

I feel like a right twit. Lol

User avatar
tincho
Posts: 41
Joined: Wednesday 10th July 2019 1:12pm

Re: Gambas runtime 3.16.0

Post by tincho » Friday 04th June 2021 7:30pm

Hi,
Maybe (I say this without testing) if you program with ide 3.16 and create the package with it, then if you install this package on a debian where there is only version 3.14 it might not work.
For example if in your program you use the Splitter control that exists from version 3.16.
Regards.

User avatar
BruceSteers
Posts: 524
Joined: Thursday 23rd July 2020 5:20pm

Re: Gambas runtime 3.16.0

Post by BruceSteers » Friday 04th June 2021 8:55pm

In project properties you can set an env variable.

GB_PCODE_VERSION = 3.8

That will stop older gambas versions refusing to run your app with bytecode error.

But also as Tincho said you have to make sure code is backward compatible and not contain commands/functiions/objects from newer gambas.

It is best to compile/ make app on the older 3.14 or test it there at least.

It's the only way to be sure.

I make my apps on 3.16 but set PCODE variable, then load them.into 3.12 on debian just to make sure they work okay.

This is the whole reason I created the gambas upgrader tools so people could upgrade gambas easier than I could make my apps backward compatible 😆
Wishing well
Bruce

If at first you don't succeed , try it differently.

AndyGable
Posts: 83
Joined: Wednesday 02nd December 2020 12:11am
Location: England
Contact:

Re: Gambas runtime 3.16.0

Post by AndyGable » Friday 04th June 2021 11:47pm

BruceSteers wrote:
Friday 04th June 2021 8:55pm
In project properties you can set an env variable.

GB_PCODE_VERSION = 3.8

That will stop older gambas versions refusing to run your app with bytecode error.

But also as Tincho said you have to make sure code is backward compatible and not contain commands/functiions/objects from newer gambas.

It is best to compile/ make app on the older 3.14 or test it there at least.

It's the only way to be sure.

I make my apps on 3.16 but set PCODE variable, then load them.into 3.12 on debian just to make sure they work okay.

This is the whole reason I created the gambas upgrader tools so people could upgrade gambas easier than I could make my apps backward compatible 😆
Thanks Bruce I shall try that when I get to the Debain PC and I will let you all know how it goes

Post Reply