Create Install package for debian

Post your Gambas programming questions here.
sadams54
Posts: 83
Joined: Monday 09th July 2018 3:43am

Create Install package for debian

Post by sadams54 » Friday 03rd September 2021 12:26am

I am using fedora but need to also distribute my software on debian and ubuntu.
When I use make installation package from the menu I create the 3 distros and the fedora works great.
The other 2 not so much... debian which is the more important one gives me about 2 dozen .deb files with names that differ only with "gtk" or "qt" and I see that with fedora also however I just grab the most generic named one and it works perfect. debian does not have one without the gtk or qt and the install packages are all 1K or under. Needless to say they do not work in debian. ubuntu I can't test until I get it working in a VM for testing.

clearly I am doing something wrong for creating installation files for debian on my fedora machine. What am I doing wrong?

User avatar
thatbruce
Posts: 19
Joined: Saturday 04th September 2021 11:29pm

Re: Create Install package for debian

Post by thatbruce » Saturday 04th September 2021 11:43pm

Firstly, clean out all the files in the target directory or change the target directory. This is so we have a "debuggable" work area.
Then, repackage your project again. BUT only generate ONE Debian based package type (preferably just Debian and not Ubuntu)
Post the package build log AND the settings you used on page 1 of the wizard.

Then we might be able to help.
b

User avatar
BruceSteers
Posts: 657
Joined: Thursday 23rd July 2020 5:20pm

Re: Create Install package for debian

Post by BruceSteers » Sunday 05th September 2021 9:51am

thatbruce wrote:
Saturday 04th September 2021 11:43pm
Firstly, clean out all the files in the target directory or change the target directory. This is so we have a "debuggable" work area.
Then, repackage your project again. BUT only generate ONE Debian based package type (preferably just Debian and not Ubuntu)
Post the package build log AND the settings you used on page 1 of the wizard.

Then we might be able to help.
b
Welcome to Gambas one Bruce :) (great name you have there ;) )

If anyone can help you with this sadams54 it's thatBruce. (He wrote some the IDE package enhancements so understands the packager stuff well)

And if there is a bug you can help too by following Bruce's steps to track the bug down. then it will get fixed :)
Wishing well
Bruce

If at first you don't succeed , try it differently.

sadams54
Posts: 83
Joined: Monday 09th July 2018 3:43am

Re: Create Install package for debian

Post by sadams54 » Tuesday 07th September 2021 10:56pm

BruceSteers wrote:
Sunday 05th September 2021 9:51am
thatbruce wrote:
Saturday 04th September 2021 11:43pm
Firstly, clean out all the files in the target directory or change the target directory. This is so we have a "debuggable" work area.
Then, repackage your project again. BUT only generate ONE Debian based package type (preferably just Debian and not Ubuntu)
Post the package build log AND the settings you used on page 1 of the wizard.

Then we might be able to help.
b
Welcome to Gambas one Bruce :) (great name you have there ;) )

If anyone can help you with this sadams54 it's thatBruce. (He wrote some the IDE package enhancements so understands the packager stuff well)

And if there is a bug you can help too by following Bruce's steps to track the bug down. then it will get fixed :)
when I tried this I got a working debian install. Seems it does not work well with the others selected. I will have to do one at a time. This however brings me to the next problem.
Seems the gambas3-runtime does not exist for debian 11? is this true or do I have to do the equivalent in fedora of installing more repos? if so how?

User avatar
thatbruce
Posts: 19
Joined: Saturday 04th September 2021 11:29pm

Re: Create Install package for debian

Post by thatbruce » Wednesday 08th September 2021 5:57pm

I will have to do one at a time.
Here's a clue, on the Destination Directory page of the wizard, there is a teeny-tiny leetle box at the bottom that says "Create directories for each distribution".
This however brings me to the next problem.
Seems the gambas3-runtime does not exist for debian 11? is this true or do I have to do the equivalent in fedora of installing more repos? if so how?
Sorry, I am afraid I have no idea what you are saying. Are you talking about the debian packagers? The Gambas team do not make the distro packages (except the ppa).

best of luck
b

sadams54
Posts: 83
Joined: Monday 09th July 2018 3:43am

Re: Create Install package for debian

Post by sadams54 » Wednesday 08th September 2021 6:51pm

thatbruce wrote:
Wednesday 08th September 2021 5:57pm
I will have to do one at a time.
Here's a clue, on the Destination Directory page of the wizard, there is a teeny-tiny leetle box at the bottom that says "Create directories for each distribution".
This however brings me to the next problem.
Seems the gambas3-runtime does not exist for debian 11? is this true or do I have to do the equivalent in fedora of installing more repos? if so how?
Sorry, I am afraid I have no idea what you are saying. Are you talking about the debian packagers? The Gambas team do not make the distro packages (except the ppa).

best of luck
b
I will try the create directories but long as they work I am good.

What I am meaning about debian is that it can't resolve the dependancy of Gambas3-runtime version 3.15 or higher. I also can't install the runtime manually as gambas3-runtime is not found in the debian repositories. I am wondering if they exist for Debian 11 or is there another repository I need to install to get to gambas runtime

User avatar
stevedee
Posts: 459
Joined: Monday 20th March 2017 6:06pm

Re: Create Install package for debian

Post by stevedee » Thursday 09th September 2021 8:59am

sadams54 wrote:
Wednesday 08th September 2021 6:51pm
...What I am meaning about debian is that it can't resolve the dependancy of Gambas3-runtime version 3.15 or higher. I also can't install the runtime manually as gambas3-runtime is not found in the debian repositories. I am wondering if they exist for Debian 11 or is there another repository I need to install to get to gambas runtime
If I'm reading this right, this page: https://packages.debian.org/source/bull ... el/gambas3
seems to indicate that Gambas runtime interpreter is included for Gambas3 v3.15.2 on Debian 11/Bullseye

So are you saying that this is not the case? Maybe double check that you are looking at the right repository.

User avatar
BruceSteers
Posts: 657
Joined: Thursday 23rd July 2020 5:20pm

Re: Create Install package for debian

Post by BruceSteers » Thursday 09th September 2021 12:03pm

My Debian11...

Code: Select all

bonus@debian:~$ apt-cache search gambas3*
gambas3 - Complete visual development environment for Gambas
gambas3-devel - Gambas compilation tools
gambas3-examples - Gambas examples
gambas3-gb-args - Gambas arguments parser
gambas3-gb-cairo - Gambas bindings for cairo
gambas3-gb-chart - Gambas charting component
gambas3-gb-clipper - Gambas Clipper component
gambas3-gb-complex - Gambas Complex component
gambas3-gb-compress - Gambas compression component
gambas3-gb-compress-bzlib2 - Gambas bzlib2 component
gambas3-gb-compress-zlib - Gambas zlib compression component
gambas3-gb-crypt - Gambas crypt encription component
gambas3-gb-data - Gambas abstract datatypes component
gambas3-gb-db - Gambas database access common libraries
gambas3-gb-db-form - Gambas database bound controls
gambas3-gb-db-mysql - MySQL driver for the Gambas database
gambas3-gb-db-odbc - ODBC driver for the Gambas database
gambas3-gb-db-postgresql - PostgreSQL driver for the Gambas database
gambas3-gb-db-sqlite3 - Gambas sqlite3 driver database
gambas3-gb-dbus - Gambas bindings for DBUS
gambas3-gb-dbus-trayicon - System tray icon management for Gambas
gambas3-gb-desktop - Gambas Portland project compatibility component
gambas3-gb-desktop-x11 - Gambas Portland project compatibility component for X11
gambas3-gb-eval-highlight - Gambas syntax highlighting component
gambas3-gb-form - Gambas native form component
gambas3-gb-form-dialog - Gambas native dialog form component
gambas3-gb-form-editor - Gambas native editor form component
gambas3-gb-form-mdi - Gambas native mdi form component
gambas3-gb-form-print - Gambas print form component
gambas3-gb-form-stock - Gambas form stock icons
gambas3-gb-form-terminal - Gambas terminal form component
gambas3-gb-gmp - Gambas GMP component
gambas3-gb-gsl - Gambas GNU Scientific Library component
gambas3-gb-gtk3 - Gambas GTK+3 component
gambas3-gb-gui - Gambas graphical toolkit selector
gambas3-gb-gui-opengl - transitional package
gambas3-gb-gui-qt - transitional package
gambas3-gb-gui-qt-webkit - transitional package
gambas3-gb-gui-trayicon - transitional package
gambas3-gb-httpd - Gambas HTTP server
gambas3-gb-image - Gambas image effects
gambas3-gb-image-effect - Gambas image effects: effects
gambas3-gb-image-imlib - Gambas image effects: IMLIB bindings
gambas3-gb-image-io - Gambas image effects: I/O
gambas3-gb-inotify - Gambas filesystem events monitoring component
gambas3-gb-jit - Gambas Just-In-Time compiler component
gambas3-gb-libxml - Gambas libxml component
gambas3-gb-logging - Gambas logging system component
gambas3-gb-map - Gambas online map viewer
gambas3-gb-markdown - Gambas markdown convert component
gambas3-gb-media - Gambas media component
gambas3-gb-media-form - Gambas media player controls
gambas3-gb-memcached - Gambas memcached client
gambas3-gb-mime - Gambas MIME message management
gambas3-gb-mysql - Gambas MySQL component
gambas3-gb-ncurses - Gambas NCurses component
gambas3-gb-net - Gambas networking component
gambas3-gb-net-curl - Gambas advanced networking component
gambas3-gb-net-pop3 - Gambas POP3 client implementation
gambas3-gb-net-smtp - Gambas smtp protocol component
gambas3-gb-openal - Gambas OpenAL component
gambas3-gb-opengl - Gambas OpenGL component
gambas3-gb-opengl-glsl - Gambas OpenGL component: GL Shading Language subcomponent
gambas3-gb-opengl-glu - Gambas OpenGL utility
gambas3-gb-opengl-sge - Gambas SDL Game Engine
gambas3-gb-openssl - Gambas OpenSSL component
gambas3-gb-option - Gambas option component
gambas3-gb-pcre - Gambas regexp component
gambas3-gb-pdf - Gambas pdf component
gambas3-gb-poppler - Gambas poppler component
gambas3-gb-qt5 - Gambas Qt5 GUI component
gambas3-gb-qt5-ext - Gambas extended Qt GUI component
gambas3-gb-qt5-opengl - Gambas OpenGL component with QT5 toolkit
gambas3-gb-qt5-webkit - Gambas WebKit component
gambas3-gb-report - Gambas report component
gambas3-gb-report2 - Gambas report2 component
gambas3-gb-scanner - Gambas scanner component
gambas3-gb-sdl - Gambas SDL component
gambas3-gb-sdl-sound - Gambas SDL sound component
gambas3-gb-sdl2 - Gambas SDL2 component
gambas3-gb-sdl2-audio - Gambas SDL2 audio component
gambas3-gb-settings - Gambas utilities class
gambas3-gb-signal - Gambas OS signal library
gambas3-gb-term - Terminal manager for Gambas
gambas3-gb-term-form - Gambas GUI terminal form component
gambas3-gb-util - This component provides many useful utility methods or classes
gambas3-gb-util-web - This component provides many utilities useful for web applications
gambas3-gb-v4l - Gambas video for Linux component
gambas3-gb-vb - Gambas Visual Basic(tm) compatibility component
gambas3-gb-web - Gambas CGI for web applications
gambas3-gb-web-feed - Gambas web feed parser and generator
gambas3-gb-web-form - Gambas web application component
gambas3-gb-web-gui - Gambas web application GUI component
gambas3-gb-xml - Gambas XML component
gambas3-gb-xml-html - Gambas HTML component
gambas3-gb-xml-rpc - Gambas RPC component
gambas3-gb-xml-xslt - Gambas XSLT component
gambas3-ide - Visual development environment for the Gambas programming language
gambas3-runtime - Gambas runtime interpreter
gambas3-scripter - Gambas scripter
That's using Debian main server

that is gambas 3.15.2

To get a newer gambas than that you have to use the autotools install and remove the 3.15.2 apt installed version.
http://gambaswiki.org/wiki/install
You're not adding the PPA are you? PPA is for Ubuntu based systems only, not debian.
Wishing well
Bruce

If at first you don't succeed , try it differently.

User avatar
BruceSteers
Posts: 657
Joined: Thursday 23rd July 2020 5:20pm

Re: Create Install package for debian

Post by BruceSteers » Thursday 09th September 2021 1:02pm

I've been down this road a few times.
This is why i made the gambas upgrader scripts/apps i did.
You either use gambas on one machine then 3.16 is just completely usable as is..

Or, for cross compatibility across other systems you have these choices...
The main problem is backward compatibility. a 3.16 app won't work on 3.15 (unless you know how) but a 3.15 will work fine on 3.16
So......

Upgrade the other systems to 3.16
Only Ubuntu/Mint/Etc can use the easiest apt PPA method
Other systems will need to use auto-tools method.


to write apps on 3.16+
You MUST ensure they have backward compatibility for older gambas versions (do not use code that did not exist on older gambas)
Ie..
You must add an Environment variable GB_PCODE_VERSION to your project in the properties window
Eg.
GB_PCODE_VERSION = 3.15
Then older gambas versions will run it and not say bytecode error.

Write apps on 3.15 gambas
(or write them on 3.16 but have gambas 3.15 on a system that you can load it and compile it/make exe)


Some tricks if using 3.16 code..
the use of "Try" can really help

For example..
[gb]
Try MyPanel.Centered = True
As Panel.Centered is a new 3.16 parameter it will raise an error if you do not use Try on 3.15.
but then your panel will not be centered on older gambas so for true compatibility you should do things the old way and not use any new code at all.
Wishing well
Bruce

If at first you don't succeed , try it differently.

User avatar
BruceSteers
Posts: 657
Joined: Thursday 23rd July 2020 5:20pm

Re: Create Install package for debian

Post by BruceSteers » Thursday 09th September 2021 1:23pm

sadams54 wrote:
Friday 03rd September 2021 12:26am
ubuntu I can't test until I get it working in a VM for testing.

clearly I am doing something wrong for creating installation files for debian on my fedora machine. What am I doing wrong?
Never mind VMs just add a partition to your hard drive and install a full speed os.

when my computer boots up i get a grub menu that gives me a choice of about 14 different os's to boot into for my testing needs.
Variants of Mint, ubuntu, debian, manjaro, mandriva, mageia,
To be honest 14 is kinda excessive if update-grub gets run it takes ages lol :)

Here's just the ones with gambas installed..
Screenshot from 2021-09-09 14-18-23.png
Screenshot from 2021-09-09 14-18-23.png (137.02 KiB) Viewed 446 times
but working with VM's is slower than the occasional update-grub command being run
Wishing well
Bruce

If at first you don't succeed , try it differently.

Post Reply