Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

User avatar
BruceSteers
Posts: 149
Joined: Thursday 23rd July 2020 5:20pm

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by BruceSteers » Wednesday 02nd September 2020 10:28pm

I just upgraded to 3.15 , for about 30 minutes.

Initially i was ready to give it a go ,
wasn't too keen on what they've done with the run button and adding arguments for testing but meh, i'd get over it.
But then....
Before i got too into the new IDE features i rebooted out of Debian where i'd upgraded and booted into Mint20 and discovered anything compiled in gambas 3.15 will only work if the user has 3.15 installed , I have the mint repositories V3.12 installed and it said Bytecode mismatch please upgrade gambas!!

Most of my software is made for the lesser geek than me and i'm thinking with all it took to install 3.15 with installing dependencies and compilation the lesser geek won't be able to use them.

So the answer to the question "Any issues with 3.15" is Yes, and i know it's not quite what you meant but I thought still a consideration worth a note.
My apps are intended for people who'll never be able to or want to install 3.15 and will just about cope with synaptic or a simple 'sudo apt-get install gambas3'
even adding a ppa is too much for some.
i think having to provide instructions on how to upgrade either using the ppa or compilation and having to completely remove the old version if they have it will just scare some people off so I'm sticking with the version the average user will have.

Or would any of you disagree?
I'm thinking a possible bash script
something like...
sudo apt-get remove -y gambas3*
sudo (cant remember command to add PPA's but add 3.15 ppa)
sudo apt-get update
sudo apt-get install -y gambas3*

Is that all it'd take?
Or am i better off sticking with 3.12?
If at first you don't succeed , try it differently.

User avatar
Quincunxian
Posts: 95
Joined: Sunday 25th June 2017 12:14am
Location: Western Australia

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by Quincunxian » Wednesday 02nd September 2020 11:59pm

I'm running 3.15.90 on Mint 20.
Once I had upgraded, I had to recompile all of my gambas apps;
changing anything with QT4 to QT5 and everything worked again.

The only issue I have now is when I am running an app from the GUI,
It sometimes takes 2-3 clicks to get the cursor to appear in a text line / text area.
I've been watching the email list and there has been no other report of this so might
be a MAMM. (Me and My Machine)
Cheers - Quin.
I code therefore I am

User avatar
Godzilla
Posts: 46
Joined: Wednesday 26th September 2018 11:20am

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by Godzilla » Thursday 03rd September 2020 6:51am

sjsepan wrote:
Saturday 01st August 2020 9:09pm
Thanks for the upgrade info; I tried it again your way and I am happy so far, except for a warning similar to yours
--Steve S

Code: Select all

(GambasGuiGeneric:56871): Gtk-WARNING **: 17:03:30.481: for_size smaller than min-size (16 < 17) while measuring gadget (node button
, owner GtkScrollbar)

(GambasGuiGeneric:56871): Gtk-WARNING **: 17:03:30.481: for_size smaller than min-size (16 < 17) while measuring gadget (node button
, owner GtkScrollbar)
Hi sjsepan, I'm glad that my route to upgrading helped someone, and that you're happy with the results.

As for these size warnings, I consider them non-issues to be ignored. I think they just mean that a control or controls hasn't been sized to the liking of GTK. Personally, for my own testing purposes, sometimes I'll have a series of radio buttons resized so that only the buttons are visible, but their labels aren't (needless space and clutter). Perhaps GTK thinks I did this by mistake and is letting me know.

cage
Posts: 80
Joined: Monday 02nd September 2019 5:47am
Location: Phoenix Arizona

Re: Any issues upgrading to Gambas 3.15 stable in Mint 19.3?

Post by cage » Thursday 03rd September 2020 7:08pm

I have had the same issue but one other that force me to us QT because this new error comes up with almost all my GTK programs.
Gtk-Error **: 11:55:27:656: Char offset -1 is off the end of the line
I have no clue what the problem is nor where the problem is at. How ever using QT the problem does not exist, so I recompiled those affected programs back to QT. This is with Gambas 3.15.1 on Arch Linux.

Post Reply