What's happening with v3.16.0 updates?

Feel free to talk about non programming issues here.
User avatar
stevedee
Posts: 429
Joined: Monday 20th March 2017 6:06pm

What's happening with v3.16.0 updates?

Post by stevedee » Sunday 25th April 2021 7:42am

I've lost count, but I seem to have had 3 or 4 updates to Gambas v3.16.0 since it was initially released, but each time, the version number remains at 3.16.0.

What's going on?

User avatar
cogier
Site Admin
Posts: 690
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: What's happening with v3.16.0 updates?

Post by cogier » Sunday 25th April 2021 9:05am

I noticed that as well. It has been updated again due to a missing file which stopped my ScreenShot program working. See here.

User avatar
sjsepan
Posts: 66
Joined: Saturday 12th October 2019 10:11pm
Location: Leeper, PA, USA
Contact:

Re: What's happening with v3.16.0 updates?

Post by sjsepan » Monday 26th April 2021 8:12pm

Just had a bunch here too, but the one today broke my Gambas.
Error during the install, something about the same item being in tools and devel.
I try opening a project and "CLibraryInfo._new.112 File or directory does not exist."
Steve S

User avatar
BruceSteers
Posts: 474
Joined: Thursday 23rd July 2020 5:20pm

Re: What's happening with v3.16.0 updates?

Post by BruceSteers » Monday 26th April 2021 8:23pm

Gambas3-devel got renamed to gambas3-dev-tools
Maybe gambas3-devel needs uninstalling?
Wishing well
Bruce

If at first you don't succeed , try it differently.

User avatar
sjsepan
Posts: 66
Joined: Saturday 12th October 2019 10:11pm
Location: Leeper, PA, USA
Contact:

Re: What's happening with v3.16.0 updates?

Post by sjsepan » Monday 26th April 2021 9:02pm

Bruce,
OK, I'll try doing that and then re-run the install. (first dump below)
UPDATE: no go; maybe I'll try the fix suggestion from apt
UPDATE2: nope. stuck
UPDATE3: tried just installing the missing item (second dump below); that seems to have worked
Steve S
---------------

Code: Select all

ssepan@*****:~$ sudo apt-get remove gambas3-devel
[sudo] password for ssepan:             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gambas3 : Depends: gambas3-dev-tools (>= 3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) but it is not going to be installed
           Depends: gambas3-devel (>= 3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) but it is not going to be installed
 gambas3-ide : Depends: gambas3-dev-tools (>= 3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) but it is not going to be installed
 gambas3-scripter : Depends: gambas3-dev-tools (>= 3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
ssepan@*****:~$
-----------------------------

Code: Select all

ssepan@*****:~$ sudo apt-get install gambas3-dev-tools
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  brave-keyring fonts-noto-hinted gir1.2-evince-3.0 gir1.2-gepub-0.6 gnome-online-miners kmymoney-common libalgorithm-c3-perl libalkimia5-7 libaqbanking-data
  libaqbanking44 libclass-c3-perl libclass-data-inheritable-perl libclass-inspector-perl libclass-singleton-perl libcue2 libdata-optlist-perl
  libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl libdatetime-timezone-perl libeval-closure-perl libevdocument3-4 libevview3-3
  libexception-class-perl libfile-sharedir-perl libfinance-quote-perl libgepub-0.6-0 libgfbgraph-0.2-0 libgsf-1-114 libgsf-1-common libgsf-bin libgwengui-cpp0
  libgwengui-qt5-0 libgwenhywfar-data libgwenhywfar79 libhal1-flash libhtml-tableextract-perl libjson-parse-perl libkchart2 libkf5webkit5 libllvm10
  libllvm10:i386 libmro-compat-perl libnamespace-autoclean-perl libofx7 libparams-util-perl libparams-validationcompiler-perl libspecio-perl
  libsub-exporter-perl libsub-install-perl libsynctex2 libtracker-control-2.0-0 libtracker-miner-2.0-0 libu2f-udev libxstring-perl libzapojit-0.0-0
  linux-headers-5.4.0-40 linux-headers-5.4.0-40-generic linux-headers-5.4.0-51 linux-headers-5.4.0-51-generic linux-headers-5.4.0-60
  linux-headers-5.4.0-60-generic linux-headers-5.4.0-65 linux-headers-5.4.0-65-generic linux-headers-5.4.0-70 linux-headers-5.4.0-70-generic
  linux-image-5.4.0-40-generic linux-image-5.4.0-51-generic linux-image-5.4.0-60-generic linux-image-5.4.0-65-generic linux-image-5.4.0-70-generic
  linux-modules-5.4.0-40-generic linux-modules-5.4.0-51-generic linux-modules-5.4.0-60-generic linux-modules-5.4.0-65-generic linux-modules-5.4.0-70-generic
  linux-modules-extra-5.4.0-40-generic linux-modules-extra-5.4.0-51-generic linux-modules-extra-5.4.0-60-generic linux-modules-extra-5.4.0-65-generic
  linux-modules-extra-5.4.0-70-generic mint-backgrounds-ulyana node-normalize.css python3-future python3-pystache unoconv
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  gambas3-dev-tools
0 upgraded, 1 newly installed, 0 to remove and 21 not upgraded.
4 not fully installed or removed.
Need to get 0 B/118 kB of archives.
After this operation, 364 kB of additional disk space will be used.
(Reading database ... 858225 files and directories currently installed.)
Preparing to unpack .../gambas3-dev-tools_3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-dev-tools (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Setting up gambas3-dev-tools (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Setting up gambas3-scripter (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Setting up gambas3-devel (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Setting up gambas3-ide (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Setting up gambas3 (3.16.0+git2021041914202.4564c5fa6+build12~ubuntu20.04.1) ...
Processing triggers for man-db (2.9.1-1) ...
ssepan@*****:~$
Last edited by sjsepan on Monday 26th April 2021 9:43pm, edited 1 time in total.

User avatar
stevedee
Posts: 429
Joined: Monday 20th March 2017 6:06pm

Re: What's happening with v3.16.0 updates?

Post by stevedee » Monday 26th April 2021 9:23pm

sjsepan wrote:
Monday 26th April 2021 8:12pm
Just had a bunch here too, but the one today broke my Gambas...
I'm glad I noticed your post Steve.

I currently have -build12 installed, but -build13 is now listed and I guess that's the one that is giving you a problem.

User avatar
sjsepan
Posts: 66
Joined: Saturday 12th October 2019 10:11pm
Location: Leeper, PA, USA
Contact:

Re: What's happening with v3.16.0 updates?

Post by sjsepan » Monday 26th April 2021 9:45pm

stevedee,
running the install for the failed package seems to have worked
Steve S

User avatar
stevedee
Posts: 429
Joined: Monday 20th March 2017 6:06pm

Re: What's happening with v3.16.0 updates?

Post by stevedee » Tuesday 27th April 2021 7:15am

sjsepan wrote:
Monday 26th April 2021 9:45pm
stevedee,
running the install for the failed package seems to have worked
Steve S
Many thanks Steve

User avatar
BruceSteers
Posts: 474
Joined: Thursday 23rd July 2020 5:20pm

Re: What's happening with v3.16.0 updates?

Post by BruceSteers » Tuesday 27th April 2021 8:59am

sjsepan wrote:
Monday 26th April 2021 9:45pm
stevedee,
running the install for the failed package seems to have worked
Steve S
Cheers Steve.
I've let Benoit know of this fix , he's trying to figure out why it all didn't just work automatically like it should have..
Wishing well
Bruce

If at first you don't succeed , try it differently.

User avatar
cogier
Site Admin
Posts: 690
Joined: Wednesday 21st September 2016 2:22pm
Location: Guernsey, Channel Islands

Re: What's happening with v3.16.0 updates?

Post by cogier » Tuesday 27th April 2021 11:41am

I currently have -build12 installed, but -build13 is now listed and I guess that's the one that is giving you a problem.
Where do you find the 'Build' information?

Post Reply